2013年4月16日火曜日

yaml とか psychのエラーでて困った

rails でbundle install とかしたときやほかでもこんなエラーがたびたびでて困った


It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.

なんだこりゃ?

調べてみてなんとか対処した

http://d.hatena.ne.jp/takehikom/20120918/1347894002


wget http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
tar xzvf yaml-0.1.4.tar.gz
cd yaml-0.1.4
./configure --prefix=$HOME/local
make
make install



vi .cshrc
set path = ($HOME/local/include $HOME/local/lib $HOME/local/bin .....
と修正
source .cshrc で反映

もいっかいruby のコンパイル
cd ruby-1.9.......
./configure --prefix=$HOME/local --with-opt-dir=$HOME/local
make
make install

--with-opt-dir=$HOME/local がけっこう大事みたい

gem install libv8 -v '3.11.8.17'
とかやるとうまくいくみたい


あれ うまくいかないな。。。。

0 件のコメント:

コメントを投稿